#1 07/09/2008 09:45

ddraw
Ньюб
Зарегистрирован: 07/09/2008
Сообщений: 2

Проблема установки пишет ошибку DOM

Есть xampp со всеми необходимыми модулями..
Установка проршла почти гладко, пришлось доводить напильником.

Теперь вот при запросе к корню выдаёт такую ошибку :



Warning: domdocument::domdocument() expects parameter 2 to be long, string given in D:\xampp\htdocs\core\framework\BaseException.class.php on line 130

Warning: domdocument::domdocument() expects parameter 2 to be long, string given in D:\xampp\htdocs\core\framework\BaseException.class.php on line 130

Warning: domdocument::domdocument() expects parameter 2 to be long, string given in D:\xampp\htdocs\core\framework\BaseException.class.php on line 130

Warning: domdocument::domdocument() expects parameter 2 to be long, string given in D:\xampp\htdocs\core\framework\BaseException.class.php on line 130

Fatal error: Uncaught exception 'SystemException' with message 'ERR_DATABASE_ERROR' in D:\xampp\htdocs\core\framework\DBA.class.php:176
Stack trace:
#0 D:\xampp\htdocs\core\framework\QAL.class.php(129): DBA->selectRequest('SELECT * FROM `...')
#1 D:\xampp\htdocs\core\framework\Language.class.php(52): QAL->select('share_languages', true, NULL, Array)
#2 D:\xampp\htdocs\core\framework\Language.class.php(73): Language->__construct()
#3 D:\xampp\htdocs\core\framework\BaseException.class.php(144): Language::getInstance()
#4 D:\xampp\htdocs\core\framework\SystemException.class.php(54): BaseException->__construct('domdocument::do...', 4, Array)
#5 D:\xampp\htdocs\core\framework\SystemException.class.php(33): SystemException->__construct('domdocument::do...', 4, Array)
#6 [internal function]: nrgnErrorHandler(2, 'domdocument::do...', 'D:\xampp\htdocs...', 130, Array)
#7 D:\xampp\htdocs\core\framework\BaseException.class.php(130): domdocument->domdocument('1.0', 'UTF-8')
#8 D:\xampp\htdocs\core\framework\SystemException.class.php( in D:\xampp\htdocs\core\framework\DBA.class.php on line 176




Пжалста решите трабл, оч надо) .

Неактивен

 

#2 08/09/2008 11:30

Pavka
Administrator
Откуда: Киев
Зарегистрирован: 10/12/2007
Сообщений: 7
Вебсайт

Re: Проблема установки пишет ошибку DOM

Такая ошибка возникает если установлена старая версия библиотеки libxml
проверь какая версия libxml через phpinfo(секция DOM)

Неактивен

 

#3 08/09/2008 18:38

ddraw
Ньюб
Зарегистрирован: 07/09/2008
Сообщений: 2

Re: Проблема установки пишет ошибку DOM

domDOM/XML         enabled
DOM/XML API Version     20031129
libxml Version        2.6.32
HTML Support                 enabled
XPath Support                 enabled
XPointer Support     enabled
Schema Support     enabled
RelaxNG Support     enabled


Помойму новее еще нет..

Отредактированно ddraw (08/09/2008 18:48)

Неактивен

 

#4 08/09/2008 23:36

Pavka
Administrator
Откуда: Киев
Зарегистрирован: 10/12/2007
Сообщений: 7
Вебсайт

Re: Проблема установки пишет ошибку DOM

Да, это самая новая версия

посмотри тогда не установлено ли расширение DOMXML (это старая версия) они могут конфликтовать с DOM

Неактивен

 

Board footer

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson